В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
КИРА28012007
КИРА28012007
21.04.2020 00:53 •  Информатика

Напишите программу, которая: а) определяет, есть ли среди цифр заданного целого трехзначного числа одинаковые; б) явл. ли число "перевертышем", т.е. числом, десятичная запись которого читается одинаково слева направо и справа налево.

Ответ:
kulikovamascha
kulikovamascha
12.07.2020 14:48
А) Program cifr;
Uses crt;
var n,l:integer; s:string;
Begin
read(n);
str(n,s);
l:=length(s);
  if (s[1]<>s[2]) and (s[2]<>s[3]) and (s[1]<>s[3])
    then begin writeln('Одинаковых цифр нет') end
    else writeln('Одинаковые цифры присутствуют');
end.

Б) Program Stroke;
Uses Crt;
Var s: string; n,i,j,l: integer;
Begin
  ReadLn(n);
  str(n,s);
  l:=length(s);
  j:=0;
for i := 1 to l div 2 do begin
  if s[i]=s[length(s)-i+1]
    then j:=1 end;
if j=1 then 
    writeln('Да, число является палиндромом')
    else writeln('Нет, число не является палиндромом');
End.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?