В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
potehin30
potehin30
29.10.2021 05:55 •  Информатика

Написать программу на паскале. дано натуральное число. вычислить среднее нечетных цифр.

Ответ:
111yo11111111111
111yo11111111111
12.07.2020 12:52
Var n, c, d, p: integer;
begin
  readln(n);
  p := 1;
  while n<>0 do begin
    d := n mod 10;
    n := n div 10;
    if d mod 2 = 1 then begin
      p := p * d;
      c := c + 1;
    end;
  end;
  
  if c = 0 then writeln (0)
  else writeln(Exp(Ln(p)/c):0:3);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?