В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Howcould
Howcould
08.05.2020 23:56 •  Информатика

Напишите программу на языке pascal.элементы массива а, удовлетворяющие условию а(i)> 5.5, переписать в массив в, а элементы, удовлетворяющие условию а(i)< =5.5, переписать в массив с. в массиве а m элементов.

Ответ:
Violettik2006
Violettik2006
12.07.2020 12:33
 var
  A,B,C: array[1..100] of integer;
  i,n,j,k:integer;
begin
randomize;
j:=0;
k:=0;
Readln(n);
Writeln('Исходный массив:');
 for i:=1 to n do
  begin
   A[i]:=random(10);
   writeln('A[',i,']=',A[i]);
   end;
for i:=1 to n do
   if A[i]>5.5
    then  
     begin
       j:=j+1;
       B[j]:=A[i];
      end;
 for i:=1 to n do
  if A[i]<=5.5
  then 
    begin
     K:=k+1;
     C[k]:=A[i];
    end;
for i:=1 to j do
 writeln('B[',i,']=', B[i]);
for i:=1 to k do
 writeln('C[',i,']=', C[i]);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?