В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык

Написать программу с использованием оператора цикла(постусловия). резервуар имеет форму сферы; его внутренний радиус равен r см найдите объем(v) жидкости в зависимости от от уровня h воды от низшей точки его дна. величина h изменяется от 0 до 2 с шагом 0,1. объем v шарового сегмента (заполненого жидкостью) вычисляется по формуле πh²(r-h/3).

Ответ:
misha223414
misha223414
12.07.2020 12:32
 const
  pi=3.14;
 var
  h,V,R: real;
begin
 writeln('Введите радиус');
 Readln(R);
 h:=0;
 repeat
   V:=pi*sqr(h)*(R-h/3);
   writeln('V(',h,')=', V);
   h:=h+0.1;
 until h>2.1;
 end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?