В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
smiley505
smiley505
18.10.2020 15:36 •  Информатика

Составьте программу которая формирует массив из 20 целых чисел и вычисляет средние арифметическое нечетный чисел

Ответ:
egmoisee
egmoisee
12.07.2020 11:41
Var mas:array[1..20] of integer;
    i, sum:integer;

begin
     for i:=1 to 20 do
     begin
          mas[i]:=random(99);
         
          write(mas[i], ' ');
     end;
    
     writeln;
    
     i:=1;
     while(i < 20) do
     begin
          sum:=sum+mas[i];
          i:=i+2;
     end;
    
     writeln('Среднее арифметическое нечётных элементов массива ', sum/10);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?