Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
ehadid
05.09.2022 07:14 •
Информатика
Написать программу, которая вводит целые числа и складывает их, пока не будет введено число 0. вывести сумму чисел , введённых до 0.
Ответ:
Priveee
12.07.2020 10:53
var
sum, num: integer;
begin
repeat
readln(num);
if (num = 0) then
break;
write(sum, ' + ', num, ' = ');
sum := sum + num;
writeln(sum);
until (false);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
Sofa8412
29.01.2021 07:04
Написать программу находящую количество цифр вводимого неотрицательного положительного числа...
magmadi1
29.01.2021 07:04
Решить на pascal е: дано целое число n и набор из n вещественных чисел. проверить, образует ли данный набор возрастающую последовательность, если образует, то вывести...
Reginalolo
22.10.2020 15:13
Решить по информатике точнее написать программу!...
maksimmolotov2
22.10.2020 15:13
Если ни один человек не может летать,а все птицы летают, построить правильное умозаключение....
andreyzher777
22.10.2020 15:13
Переведите 10101100 2 в десятичную систему счисления....
filyanarasulov
05.11.2021 04:15
В таблице представлены изображения...
блабла70
17.10.2022 13:00
Якщо кількість повторень у циклічному алгоритмі наперед визначена, то отримаємо…? Виберіть одну відповідь: розгалуження цикл з передумовою цикл з післяумовою зациклення...
katirina19
17.06.2021 10:56
Запиши по три слова: с без ударной гласной в корне,с непроизносимой согласной,с удвоенной согласной,с разделительным ъ,с чк-чн,с парной согласной в середине слова...
Julia517517
17.06.2021 10:56
Спадежами в густой траве.на лесных полянах.душистые фиалки.росли в траве.росли на полянах....
Masha07041
09.05.2022 15:09
Мне надо и желательно побыстрей - ответить на вопрос по сказке-были кладовая солнца ! с какой целью подробно рассказывается об антипыче и его правде,о собаке травке и...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
sum, num: integer;
begin
repeat
readln(num);
if (num = 0) then
break;
write(sum, ' + ', num, ' = ');
sum := sum + num;
writeln(sum);
until (false);
end.