В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
нургалым1
нургалым1
10.06.2021 14:46 •  Информатика

Составить программу в которой записать в массив n номера положительных элементов массива (x1,)

Ответ:
finicot
finicot
25.05.2020 14:19

var

  N: array [1..15] of 1..15; {Массив, в который записываются номера положительных элементов массива х}

  x: array [1..15] of real; //Массив х

  i: integer; //Переменная для цикла

  Number: integer; //Сколько номеров было записано

begin

  Number:= 0; //Обнуляем счетчик номеров

  for i:= 1 to 15 do   //Вводим с клавиатуры массив х

  begin

    writeln('Введите ', i, ' элемент массива х');

    readln(x[i]);

    if x[i] > 0 then  {Если введенный элемент массива х положительный, то прибавляем к счетчику добавленных номеров 1 и присваиваем соответствующему элементу массива N номер элемента}

    begin

      Number:= Number + 1;

      N[Number]:= i;

    end;

  end;

  write('Номера положительных элементов массива х:  ');

  for i:= 1 to Number do write(n[i], '  '); //Выводим записанные номера элементов

  writeln; {Переход на новую строку, чтобы при следующем запуске программы информация выводилась с новой строки}

end.

 

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?