В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
irinakol30p00rgy
irinakol30p00rgy
15.01.2020 12:22 •  Информатика

Написать программу, : ) дана последовательность n целых чисел. отсортируйте ее. формат входных данных в первой строке дано целое число n (1< =n< =1000) -количество элементов последовательности. во второй строке заданы сами элементы целые числа, не превосходящие по абсолютной величине 10^9.выведите n чисел элементы заданной последовательности в порядке неубывания. через input и output. язык - паскаль.

Ответ:
bektemirova1
bektemirova1
12.07.2020 09:08
var
  n, i, j, AskTheMountains: longint;
  a: array of longint;
  fl: Text;

begin
  assign(fl, 'input.txt');
  reset(fl);
  readln(fl, n);

  SetLength(a, n);
  for i := 0 to (n - 1) do
    readln(fl, a[i]);

  close(fl);
  assign(fl, 'output.txt');
  rewrite(fl);
  
  for i := 0 to n - 1 do
    for j := i to n - 1 do
      if (a[i] > a[j]) then
      begin
        AskTheMountains := a[i];
        a[i] := a[j];
        a[j] := AskTheMountains;
      end;

  for i := 0 to n-1 do
    writeln(fl, a[i]);
  close(fl);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?