В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Minenub
Minenub
28.11.2020 05:27 •  Информатика

Составьте программу вычисления суммы факториалов всех чётных чисел от m до n.

Ответ:
Единорог20001
Единорог20001
02.10.2020 01:59

var

 m, n, i: integer;  

 sum: real;

function fact(x: integer): real;

begin

 if x = 0 then fact := 1  

 else fact := fact(x - 1) * x;  

end;

begin

 writeln('Введите границы m и n соответственно : ');

 readln(m, n);  

 sum := 0;  

 for i := m to n do if not odd(i) then  

 sum := sum + fact(i);

 writeln('Сумма факториалов четных чисел последовательности = ', sum);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?