В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
KRMP037
KRMP037
24.12.2021 09:29 •  Информатика

Pascal.составьте программу для нахождения суммы отрицательных четных элементов двумерного массива

Ответ:
aynuran1
aynuran1
02.10.2020 02:01
Program aliona;
const n =10;
var a:array[1..n,1..n] of integer;
i,j,s:integer;
begin
randomize;
for i:=1 to n do
for j:=1 to n do 
begin
a[i,j]:=random(30); 
write ( 'а(', i, ',', j, ')=', a[i,j]);
end ;
s:=0;
for i:=1 to n do begin
for j:=1 to n do begin
if a[i] (mod 2 =0) and (a[i]<0) then s:=s+a[i];
writeln('s=',s);
readln;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?