В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
kirifili007
kirifili007
15.07.2020 12:18 •  Информатика

Написать программу определения максимального числа последовательности положительных чисел, вводимых с клавиатуры, до тех пор, пока не будет введён 0. (циклом с предусловием в pascalabc), на фото программа с постусловием. а решить надо с предусловием.

Ответ:
незнайка1186
незнайка1186
02.10.2020 01:51

var x, max: integer;

begin

x:=-1;

max:=-1;

while x<>0 do

 begin

   readln(x);

   if x=0

     then break;

   if x>max

     then max:=x;

 end;

if (max < 1)

 then writeln('Нет чисел, удовлетворяющих условию')

else writeln ('Максимальное число: ', max);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?