В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
tach11
tach11
08.02.2022 15:06 •  Информатика

Составить программу для нахождения наибольшего общего делителя двух натуральных чисел m и n.

Ответ:
Gerdu
Gerdu
12.07.2020 01:33
Pascal

var a,b,i,c,d:integer;
begin
writeln ('Введите два натуральных числа');
readln (a,b);
if (a>0) and (b>0) then begin
if (a=b) then writeln ('НОД = ',a) else begin
if (a>b) then c:=a else c:=b;
for i:=1 to c do begin
if (a mod i=0) and (b mod i=0) then d:=i;
end;
writeln ('НОД = ',d);
end;
end else writeln ('Неверный ввод');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?