В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Est19xx1
Est19xx1
02.04.2021 10:50 •  Информатика

Дан целочисленный массив из 10 элементов все элементы которого целые числа в интервале от - 1000 до 1000. напишите программу которая находит количество элементов всех нечетных элементов массива которые делятся на 3 на языке pascal желательно

Ответ:
fukurochanmiup04xjx
fukurochanmiup04xjx
02.10.2020 01:35
var   a: array [1..30] of integer;
i,k: integer;
begin

k:=0;
все в цикле (примерно так: for i:=1 to 10 do...)(это чтобы прокручивать цикл)
if ((a[i] mod 2=1) and (a[i] mod 3=0)) then k=k+1;
writeln(k);end.
что-то вроде этого,я уже точно не помню язык pascal; 
0,0(0 оценок)
Ответ:
Zarina2206
Zarina2206
02.10.2020 01:35
Program E08;
  uses crt;
    var
      X: array[-1000..1000] of integer;
      S,i,k: integer;
begin
  clrscr;
  writeln('Введите массив X:');
  for i:=1 to 10 do
    begin
      write('X[',i:2,'] ==> ');
      readln(X[i])
    end;
      for i:=1 to 10 do
    write(X[i],' ');
    writeln;

  K:=0;

    for i:=1 to 10 do
    begin
      S:=X[i] mod 3;
      if S = 0 then
        K:=K+1
    end;
      writeln('ответ: ',K)
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?