В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
cat9913
cat9913
29.01.2020 05:57 •  Информатика

Составить программу, проверяющую является ли число палиндромом

Ответ:
nata1116
nata1116
10.07.2020 22:45
Var S1, S2 : String; N : Byte; Error : Boolean; 
begin 
Write('Введите натуральное число: '); ReadLn(S1); 
Error := False; S2 := ''; for N := 1 to Length(S1) do if S1[N] in ['0'..'9'] then S2 := S1[N] + S2 else Error := True; 
if Error then WriteLn('В числе должны быть только цифры! ') 
else if S1 = S2 then WriteLn('Введённое число - является полиндромом. ') 
else WriteLn('Введённое число - не является полиндромом. ') 
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?