В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
niknikiforov91
niknikiforov91
23.03.2021 23:46 •  Информатика

Pascalabc. составьте программу рисования ряда треугольников с использованием процедуры triangle.

Ответ:
салссо1232960
салссо1232960
25.05.2020 13:27

uses GraphABC;

var

 i, tmp: integer;

procedure Triangle(x, y, x2, y2, x3, y3: integer);

begin

 line(x, y, x2, y2);

 line(x2, y2, x3, y3);

 line(x3, y3, x, y);

end;

begin

 SetWindowSize(600, 300);

 for i := 0 to 5 do

 begin

   tmp := i * 100;

   Triangle(0 + tmp, 200, 50 + tmo, 100, 100 + tmp, 200);

 end;

end.

0,0(0 оценок)
Ответ:
Valya039782
Valya039782
16.01.2024 21:32
Конечно, я могу помочь с этим вопросом!

Прежде всего, давайте создадим процедуру triangle, которая будет рисовать треугольник. Вот как это можно сделать на языке программирования PascalABC:

program DrawTriangles;

uses crt;

procedure Triangle(n: integer);
var
i, j: integer;
begin
// Внешний цикл отвечает за количество строк
for i := 1 to n do
begin
// Внутренний цикл отвечает за количество символов в строке
for j := 1 to i do
write('*');
writeln;
end;
end;

begin
Triangle(5); // Вызываем процедуру triangle с параметром 5
readln;
end.

Давайте разберемся, как работает данная программа.

Мы создаем процедуру triangle, которая имеет один параметр - n (количество треугольников). Внутри процедуры у нас есть два цикла – внешний и внутренний. Внешний цикл выводит строки, а внутренний цикл рисует символы в каждой строке. Увеличение количества символов в строке происходит по мере прохождения внешнего цикла.

Мы вызываем процедуру triangle и передаем значение 5 в качестве параметра. Это означает, что программа будет рисовать пять треугольников.

Теперь давайте рассмотрим, как будут выглядеть треугольники, которые нарисует данная программа:

*
**
***
****
*****

В данном случае, количество строк в каждом треугольнике соответствует числу, переданному в процедуру triangle.

Если тебе нужно нарисовать другое количество треугольников, ты можешь изменить значение в вызове процедуры triangle.

Надеюсь, это помогло! Если у тебя возникнут еще вопросы, не стесняйся задавать!
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?