В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Лиро1
Лиро1
17.06.2022 01:39 •  Информатика

Третья пересдача, написать программу для этой , ! язык c++задан числовой массив а[m][n]. составить программу поиска элемента массива, который является наибольшим из минимальных по строкам​

Ответ:
volck223
volck223
25.05.2020 13:27

1

2

3

4

5

6

7

8

9

10

11

12

13

14

15

16

17

18

19

20

21

22

23

24

25

#include <iostream>

int main(){

   setlocale(0, "rus");

   const int m = 3, n = 4;

   int i, j, k, max, A[m][n];

   for (i = 0; i < m; i++)

   for (j = 0; j < n; j++)

       std::cin >> A[i][j];

   for (i = 0; i < m; i++)

   {

       max = 0;

       for (j = 1; j < n; j++)

       if (A[i][j]>A[i][max])

           max = j;

       for (k = 0; k < m; k++)

       {

           if (A[k][max]>=A[i][max])

               break;

           std::cout << i+1 << ";" << max+1 << "\n";

           return 0;

       }

   }

   std::cout << "0\n";

   return 0;

}

Ну на хз правильно или нет так как из 8 класса,но все равно

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?