В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Papitto
Papitto
06.07.2022 20:16 •  Информатика

Составьте быстро! 1)составьте программу вычесления суммы s=1+2^2+3^3+4^4++n^n. 2)даны годовые оценки учеников класса по .верно ли ,что количесвто пятерок больше,чем двоек? 3)известна высота двадцати зданий.найти минимальную высоту. 4известна высота двадцати зданий.найти два максимальный значения

Ответ:
F1RE000
F1RE000
10.07.2020 19:55
Var p, q: longint;
  n, i, j, c: integer;
begin 
  // 1
  write('n=');readln(n);
  for i := 1 to n do begin
    q := 1;
    for j := 1 to i do q := q * i;
    p := p + q;
  end;
  writeln ('Значение = ', p);
  
  // 2
  write('Число годовых оценок=');readln(n);
  p:=0;
  for i := 1 to n do begin
    write('оценка: '); readln(c);
    if c = 5 then p := p + 1
    else if c = 2 then p := - 1;
  end;
  writeln(p > 0);
  
  // 3
  n := 20; p := MaxInt;
  for i := 1 to n do begin
    write('Введите высоту здания ', i, ': ');
    readln(c);
    if c < p then p := c;
  end;
  writeln('Минимальная высота: ', p);
  
  //4
  n := 20; p := -1;
  for i := 1 to n do begin
    write('Введите высоту здания ', i, ': ');
    readln(c);
    if c > p then p := c;
  end;
  writeln('Максимальное значение высоты: ', p);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?