В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
ilia113
ilia113
21.01.2021 10:31 •  Информатика

Дан одномерный массив из n целых чисел. составить программу нахождения максимального и минимального элементов.

Ответ:
AlexCameron
AlexCameron
10.07.2020 19:29
Var a:array of integer;
  i,n,mn,mx: integer;
begin
  write('размерность массива = ');
  readln(n);
  SetLength(a, n);
  for i := 0 to n-1 do begin
    write('a[',i,']=');
    readln(a[i]);
  end;
  
  mn := a[0]; 
  mx := a[0];
  for i := 1 to n-1 do begin
    if mn > a[i] then mn := a[i];
    if mx < a[i] then mx := a[i];
  end;
  
  writeln('минимальный элемент = ', mn);
  writeln('максимальный элемент = ', mx);
end.
  
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?