В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
MrNikitkahelp
MrNikitkahelp
21.09.2021 13:08 •  Информатика

Втурбо паскале уже нужно составить программу для обработки массива содержащего 10 целых числе. определить максимальный элемент массива. выполнение каждого логического блока программы оформить в виде отдельных процедур

Ответ:
az34358strelok8390
az34358strelok8390
10.07.2020 19:23
Uses crt;
var i,j,k,n,max:integer; a:array[1..100] of integer;
procedure rmassr;
begin
    for i:=1 to n do
    a[i]:=random(10);
end;
procedure rmassy;
begin
    for i:=1 to n do
    readln(a[i]);
end;
procedure maxe;
begin
max:=a[1];
    for i:=2 to n do begin
        if a[i] > max then max:=a[i];
    end;
    writeln('max element = ', max);
end;
procedure wmass;
begin
    for i:=1 to n do
    write(a[i],' ');
    writeln;
end;
begin
clrscr;
randomize;
write('Длина массива'); readln(n);
write('1-random; 2- в ручную '); readln(k);
if k=1 then rmassr()
else rmassy();
wmass();
maxe();
readln
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?