В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Tinka123
Tinka123
17.04.2020 01:36 •  Информатика

Написать программу с использованием оператора while do вот в начале тренировочного периода лыжник во время тренировки пробегал 5 км,каждый день он увеличивал нагрузку на 5%.рассчитать через какое время нагрузка лыжника во время тренировки превысит 20км

Ответ:
dradya
dradya
10.07.2020 19:16
Лучше перепроверить.
0,0(0 оценок)
Ответ:
Мигает333
Мигает333
10.07.2020 19:16
Var 
a, b, c, summ, d, den:real;
beginwrite('Введите кол-во км начальные: ');readln(a);
write('Введите на сколько % увеличивается расстояние каждый день: ');readln(b);
write('Введите, до скольки КМ увеличивает расстояние в день лыжник: ');readln(c);

den:=0;
while a<c do begin  d:=a/100*b; // узнаем, на сколько увеличивается растояние  a:=a+d;  den:=den+1;  end;     writeln(den);
end.

Написал на Pascal. Вводить можно любые данные ( не только, которые вы дали)
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?