В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
grbennikovigor
grbennikovigor
19.10.2021 21:14 •  Информатика

Нужно написать программу паскаль.. 7.62. даны натуральное число n и целые числа a1, a2, a3, …a9. найти: а) номер максимального из чисел ai,. если чисел с максимальным значением несколько, то должен быть найден номер последнего из них; б) номер минимального из чисел ai,. если чисел с минимальным значением несколько, то должен быть найден номер первого из них;

Ответ:
lllllll47900732
lllllll47900732
25.05.2020 12:55

program asd;
uses crt;
var
i:integer;
a: array[1..9] of integer;
naibnum:integer;
naib:integer;
naim:integer;
naimnum:integer;
begin
writeln('Вводите цифры');
for i:=1 to 9 do
begin
readln(a[i]);

if i = 1 then naim:=a[i];
if i = 1 then naib:=a[i];
if a[i] < naim then
begin
naim:=a[i];
naimnum:=i;
end;

if a[i] > naib then
begin
naib:=a[i];
naibnum:=i;
end;
end;

writeln('Наименьшее:',naim, ' номер:', naimnum);
writeln('Наибольшее:',naib, ' номер:', naibnum);
end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?