В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Veronika72563
Veronika72563
27.03.2021 18:35 •  Информатика

Составьте программу вычисления произведения тех значений элементов двумерного массива, которые меньше 15. паскаль

Ответ:
RushShru
RushShru
25.05.2020 12:46

Условие элемент массива меньше 15 и не равен нулю потому, что иначе произведение почти всегда будет равно нулю. Если оно не нужно - удали фрагмент      'and(a[i,j]<>0)'

Program n1;
Uses CRT;
Const n=10;
Var a: array[1..n,1..n] of integer;
i,j: integer; p: longint;
begin
p:=1;
For i:=1 to n do
begin
For j:=1 to n do
begin
a[i,j]:=random(50);
if (a[i,j]<15)and(a[i,j]<>0) then p:=p*a[i,j];
write(a[i,j]:3);
end;
writeln;
end;
writeln('Proizvedenie =',p);
readln
end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?