В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Adn2001
Adn2001
28.10.2021 18:39 •  Информатика

Написать программу которая определяет число полиндром паскаль (ну или хотя бы идейку подкиньте)

Ответ:
ksyu5551
ksyu5551
10.07.2020 09:32
Program palindrom;
Uses crt;
var    s: string;
    i,f: byte;
begin 
clrscr;
   write('String: ');
    readln(s);
    f := 0;
    for i := 1 to length(s) div 2 do        if s[i] <> s[length(s)-i+1] then begin            writeln('No palindrome');
            f := 1;
            break       
end;
    if f = 0 then        write('Palindrome');
readln
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?