Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
ЕсенжоловаЛяззат
06.04.2021 19:33 •
Информатика
Написать программу в паскаль абс: -d задан проходной . запрашиваются оценки абитуриента на 4 экзаменах и сообщается о результате приема в институт.
Ответ:
viktoria383
10.07.2020 08:23
Готово
0,0
(0 оценок)
Ответ:
123451527
10.07.2020 08:23
Вот так задача решается без массивов:
program score;
var a,b,c,d,sc:integer;
res:integer;
begin
write('Input 1st exam score:');
readln(a);
write('Input 2nd exam score:');
readln(b);
write('Input 3rd exam score:');
readln(c);
write('Input 4th exam score:');
readln(d);
write('Input pass score:');
readln(sc);
if (a+b+c+d) <sc then writeln ('NOT PASSED') else writeln('PASSED');
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
patoga79p00pc3
02.04.2023 23:26
Сравните различные форматы, выделяя плюсы и минусы: а) .bmp и .jpg b) .mp3 и .wav...
karevmaxim4974owjcrc
05.02.2020 20:57
Напишите программу в среде графического исполнителя Робот для решения следующей задачи: Закрасить рабочее поле горизонтальными пунктирными линиями...
karinatom9
05.02.2022 19:25
Палитрой в графическом редакторе являются......
Nataliya49017
08.12.2020 15:36
Дан массив из n элементов. Необходимо поменять элементы местами, вывести их на печать. Отсортируйте массив в порядке возрастания–вывести на печать, убывания–вывести...
EGORchikchik228
14.09.2022 06:37
Переведите в десятичную систему двоичное число 111001101...
aidanuraim
14.09.2022 06:37
Имеется колода из 32 игральных карт(без шестерок)задумана одна из карт.какое наименьшее число вопросов нужно задать чтобы угадать задуманную карту ,если на вопросы...
aidana70
28.02.2020 19:29
Задумано целое число от нуля до ста.какое наименьшее число вопросов надо задать,чтобы угадать это число ?...
svetusik214
28.02.2020 19:29
По одному примеру истинного и ложного высказываний...
lanedaGo
28.02.2020 19:29
Переведите из 10 исной системы в 2 ичн число 0,321...
alinamazur003
02.06.2020 10:10
Для какого числа X истинно высказывание ((X 5) → (X 3)) * ((X 2) → (X 1)) Варианты: 1, 2, 3, 4...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
program score;
var a,b,c,d,sc:integer;
res:integer;
begin
write('Input 1st exam score:');
readln(a);
write('Input 2nd exam score:');
readln(b);
write('Input 3rd exam score:');
readln(c);
write('Input 4th exam score:');
readln(d);
write('Input pass score:');
readln(sc);
if (a+b+c+d) <sc then writeln ('NOT PASSED') else writeln('PASSED');
end.