В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
МаШкА428
МаШкА428
17.05.2022 11:31 •  Информатика

Склавиатуры вводят слово.составить программу ,которая: а)определяет количество символов в нём б)проверяет,не ли первая и последняя буквы слова в)выводт на экран первый,второй и последний символы г)определяет,чётно или нечётно количество символов в нём

Ответ:
Саидушка2006
Саидушка2006
25.05.2020 12:02

uses crt;
var s: string;
begin
writeln('Напишите слово');
readln(s);
writeln(length(s) ,' символов');

writeln(s[1] ,' первый символ ', s[2] ,' второй символ ', s[length(s)] ,' последний символ');

if (s[length(s)] = s[1]) then
begin
writeln('совпадают');
end
else writeln('не совпадают');
if (length(s) mod 2 = 0) then
begin
writeln('четное кол-во');
end
else writeln('не четное');

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?