В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык

Составить программу, которая подсчитывает общее количество целых пятизначных чисел, составленных из различных цифр, которые тем свойством, что число, образованное первыми двумя цифрами, будучи умноженным на среднюю цифру, даёт число, образованное последними двумя цифрами.

Ответ:
katyusha0
katyusha0
09.07.2020 22:48
Var
  a, b, c, d, e, n: integer;

begin
  n := 0;
  for a := 1 to 9 do
    for b := 0 to 9 do
      for c := 1 to 9 do
        for d := 0 to 9 do
          for e := 0 to 9 do
            if (10 * a + b) * c = (10 * d + e) then n := n + 1;
  Writeln(n)
end.

Тестовое решение:
196
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?