В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
RDD1
RDD1
30.05.2022 04:02 •  Информатика

Разработать алгоритм и составить программу на выбранном языке программирования ( паскаль или qbasic) для нахождения произведения цифр числа, полученного при умножении числа 12 на свой порядковый номер в списке группы.

Ответ:
маришка197
маришка197
09.07.2020 19:20
Var
  m, n, p: integer;

begin
  Write('Введите свой номер в группе: ');
  Readln(n);
  n := n * 12;
  p := 1;
  repeat
    m := n mod 10;
    p := p * m;
    n := n div 10
  until n = 0;
  Writeln('Результат ', p)
end.

Тестовое решение:

Введите свой номер в группе: 13
Результат 30
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?