Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
ПАПА1111111111
12.08.2021 10:35 •
Информатика
Программу на си. найти все трехзначные числа, сумма цифр которых равна данному целому числу.
Ответ:
Ymnusha
09.07.2020 16:04
#include <stdio.h>
int main()
{
int a;
scanf("%d", &a);
for(int i = 100;i < 1000;i++)
{
if((i % 10 + ((i % 100 - i % 10) / 10) + (((i- i % 10 ) / 10) - i % 10) / 10)) == a)
{
printf("%d", i);
}
}
}
Правда это слегка кустарный решения
0,0
(0 оценок)
Популярные вопросы: Информатика
Alina25255
02.07.2020 15:12
Уисполнителя квадратор две команды, которым присвоены номера: 1. возведи в квадрат 2. вычти 2 первая из них возводит число на экране во вторую степень, вторая — вычитает из числа...
алькамалька
04.07.2020 14:21
Запишите число 3015 в десятичной системе счисления...
qmerry128
09.08.2020 03:46
Сколько символов текста можно передать за 5 секунд, используя телефонный канал,работающий со скоростью 56 кбит/с?...
gukuwa09
09.08.2020 03:46
Напишите программу вычисления произведений.(turbo pascal) (x-1)(x-2)(x--n);...
kris406
02.12.2021 00:31
Программа паскаль. составить программу, чтобы получились, как минимум 5 слов из слова романтика...
katiaefimova
29.03.2021 08:40
Алфавит состоит из 1000 букв. какое количество информации несет одна буква этого алфавита?...
Angelina1355555
13.02.2020 12:16
заполните массив случайными числами в интервале [0; 100] и подсчитайте отдельно среднее значение всех элементов,которые меньше 50, и среднее значение всех элементов,которые больше...
Сабина14090402929929
30.05.2023 16:11
Вопрос 1что представляет собой visual basic? система программирования среда проектирования объединяет в себе систему программирования и среду проектированиявопрос 2каким образом...
yasasmail
30.05.2023 16:11
Продолжите: школа-обучение= а)доктор б)ученик в)больной г)лечение бежать-стоять= а)ползать б)молчать в)плакать г)шуметь выберите нужное понятие к !...
valovaliza2018
30.05.2023 16:11
Переведите число 140 из десятичной системы счисления в двоичную систему счисления. распишите все свои действия...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
int main()
{
int a;
scanf("%d", &a);
for(int i = 100;i < 1000;i++)
{
if((i % 10 + ((i % 100 - i % 10) / 10) + (((i- i % 10 ) / 10) - i % 10) / 10)) == a)
{
printf("%d", i);
}
}
}
Правда это слегка кустарный решения