В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Irakyn
Irakyn
23.06.2021 06:39 •  Информатика

Составить программу в паскале: из n введенных чисел найти максимальное значение среди положительных элементов.

Ответ:
наталинка1975
наталинка1975
09.07.2020 13:29
Текст программы в документе.
0,0(0 оценок)
Ответ:
BeemayaS
BeemayaS
09.07.2020 13:29
Program abc;
type 
   mas = array[0..1000] of integer;
var 
   a: mas;
   i, n, max: integer;
begin
  WriteLn('Введите кол-во эл-тов массива:');
  ReadLn(n);
  for i := 1 to n do
  begin
    WriteLn('Введите значение элемента №', i);
    ReadLn(a[i]);
  end;
  WriteLn('Все элементы массива имеют значение');
  max := -1;
  for i := 1 to n do
    if a[i] > max then
      max := a[i];
    if max <> -1 then
      Writeln('Максимальное значение положительного элемент = ', max)
    else Writeln('Положительных элементов нет');
    ReadLn;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?