В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
ruslanlezgi
ruslanlezgi
28.05.2020 00:25 •  Информатика

Составить алгоритм и написать программу для решение с использованием двумерных массивов и конструкций цикла в цикле: вычислить сумму положительных элементов матрицы а (10х10), расположенных над главной диагональю. индекс номера строки i изменяется от 1 до 9, а индекс номера столбца j изменяется от –i+1 до 10.

Ответ:
657алЕНА
657алЕНА
09.07.2020 12:57
Var a:array[1..10,1..10] of integer;
i,j,sum,np: integer;
begin
for i:=1 to 10 do 
 for j:=1 to 10 do readln(a[i,j]);
sum:=0;
for np:=1 to 9 do begin
 i:=np; 
 for j:=1 to np do begin 
  if a[i,j]>0 then sum:=sum+a[i,j]; 
  i:=i-1; 
 end;
end; 
writeln('Сумма элементов, расположенных выше главной диагонали равна ',sum);
readln
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?