В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Элника
Элника
24.01.2020 19:32 •  Информатика

Pascal abc 1 составить программу которая запрашивает целое число не равное нулю сообщает положительное они или отрицательное и при этом положительное число уменьшает в 2 раза, отрицательные возводит в квадрат . 2 составить программу , которая определяет является ли введенное число нечетным и выводит на экран сообщение да или нет .

Ответ:
sanya1130
sanya1130
09.07.2020 12:43
Первая программа ,если не нравится исправлю
Добавил вторую
0,0(0 оценок)
Ответ:
Lego40
Lego40
09.07.2020 12:43
1.
Program ZADACHA;
Uses crt;

var a: integer;

Begin clrscr;
      write('Введите целое число не равное нулю a = ');
      readln(a);
      writeln;
      if a<0 then
      Write('Число a отрицательное, результат = ', a*a)
     
      else
      Write('Число a положительное, результат = ', a/2);

End.

2.
Program CHETNOST;
Uses crt;

var a: integer;

Begin clrscr;
      write('Введите целое число a = ');
      readln(a);
      writeln;
      if (a mod 2) = 1 then
      Write('Да')
      else
      Write('Нет');

End.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?