В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Пепечка
Пепечка
30.04.2023 22:00 •  Информатика

Составьте программу решения квадратного уравнения ax(во второй степени) + bx + c = 0. коэффициенты a,b,c введите с клавиатуры. выведите на экран значение корней x1,x2, если уравнение имеет два корня, значение x, если уравнение имеет один корень, или сообщение "нет корней" , если уравнение не имеет корней. составьте программу на уровне 8 класса.

Ответ:
kirillstetskii
kirillstetskii
09.07.2020 12:26
var
  a, b, c: real;

begin
  readln(a, b, c);
  if (sqr(b) - 4 * a * c < 0) then
    writeln('Нет решений')
  else
    if (sqr(b) - 4 * a * c = 0) then
      writeln('x = ', (-1 * b) / (2 * a))
    else
    begin
      writeln('x1 = ', (-1 * b + sqrt(sqr(b) - 4 * a * c)) / (2 * a));
      writeln('x2 = ', (-1 * b - sqrt(sqr(b) - 4 * a * c)) / (2 * a));
    end;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?