В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
ikilan201
ikilan201
18.07.2020 14:12 •  Информатика

Составить программу обмена местами максимума и минимума в массиве

Ответ:
stalker2000008
stalker2000008
02.10.2020 00:06
Var a:array[1..1000] of integer;
N,max,max1,min,min1,i: integer;
begin
writeln('Введите количество элементов'); readln(N);
min:=32768; max:=-32768;
for i:=1 to N do begin
 readln(a[i]);
 if a[i]>max then begin max:=a[i]; max1:=i; end;
 if a[i]<min then begin min:=a[i]; min1:=i; end; 
end;
if (max<>-32769)and(min<>32768) then begin
 i:=a[max1]; a[max1]:=min; a[min1]:=i; end
else writeln('Обмен невозможен'); 
readln
end.
0,0(0 оценок)
Ответ:
danil67896430643
danil67896430643
02.10.2020 00:06
var a, b, c, i, n, max, min:integer;
    s :array [1..10000] of integer;
begin
   read (n);
   for i:=1 to n do
      read (s[i]);
   max:=s[1];
   min:=s[1];
   a:=1;
   b:=1;
   for i:=1 to n do
      begin
      if s[i]>=max then
          begin
         max:=s[i];
         a:=i;
         end;
      if s[i]<min then
         begin
         min:=s[i];
         b:=i;
         end;
      end;
   s[a]:=min;
   s[b]:=max;
   writeln;
   for i:=1 to n do
      write (s[i],' ');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?