В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
алишер126
алишер126
04.02.2021 19:46 •  Информатика

Язык pascalabc или python максимальные . с клавиатуры вводятся координаты (x,y) двух точек a и b (координаты могут быть отрицательными, положительными или нулевыми)нужно написать программу, которая находит расстояние от точки a до b

Ответ:
ikurgan
ikurgan
09.07.2020 07:53

program zz1;

var x1, x2, y1, y2, d: real; //задаем переменные не целого типа

begin

write(' введите координаты точки а '); // вводим с клавиатуры координату х и координату у первой точки

read(x1, y1);  

write('введите координаты точки b '); // вводим с клавиатуры координату х и координату у второй точки

read(x2, y2);

d:=sqrt(sqr(x1 - x2) + sqr(y1 - y2));   // находим длину отрезка по формуле

write(' длина отрезка ab = ', d:5:2); // выводим ответ в формате пять знаков для числа и два знака после точки

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?