В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
prokop228
prokop228
26.12.2021 00:53 •  Информатика

Написать программу на паскале, которая вводит массив из n целых чисел и выводит на экран номера отрицательных элементов и сами эти элементы. протестировать программу для следующих массивов: а) 3 5 -2 0 -6 -8 1 б) -1 -2 -3 0 -1 2 3 массивы должны вводися вручную а не рандомно.

Ответ:
lisisiisissi
lisisiisissi
25.05.2020 08:40

var a: array[1..100] of integer;

n, i: integer;

begin

write('Введите количество элементов массива');

readln(n);

write('Вводите элементы массива отделяя их клавишей "Enter"');

for i:=1 to n do 

read(a[i]);

for i:=1 to n do 

if a[i]<0 then write('число ', a[i], ', номер ', i,'; ' );

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?