В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Tcgdfh
Tcgdfh
21.12.2021 08:11 •  Информатика

Написать программу при выполнение которой с клавиатуры вводятся 10 целых чисел.программа выводит кол-во чисел кратных 5 и её произведение.

Ответ:
belatarikova
belatarikova
08.07.2020 18:55
Var
  a : array [1..10] of integer;
  count, prod, i : integer;
begin
  count := 0;
  prod := 1;
  for i := 1 to 10 do read (a[i]);
  for i := 1 to 10 do
    if a[i] mod 5 = 0 then
    begin
      count := count + 1;
      prod := prod * a[i];
    end;
  if count > 1 then write (count, ' ', prod) else write ('таких чисел нет');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?