В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Karina0714
Karina0714
19.12.2022 07:48 •  Информатика

Надо. написать программу с цикла, которая позволяет ввести с клавиатуры последовательность из трех дробных чисел и после ввода каждого числа выводит среднее арифметическое полученной части последовательности. ниже представлен рекомендуемый вид экрана во время работы программы: *обработка последовательности дробных чисел* после ввода каждого числа нажмите - > 12.3 введено чисел: 1 среднее арифметическое: 12.30 - > 15 введено чисел: 2 среднее арифметическое: 13.65 - > 10 введено чисел: 3 среднее арифметическое: 12.43

Ответ:
mashauuu6
mashauuu6
25.05.2020 08:38

var a: array[1..3] of real;

x: real;
i: shortint;
begin
writeln('После ввода каждого числа нажмите <Enter>');
a[1]:=0; a[2]:=0; a[3]:=0;
for i:=1 to 3 do begin
write('->');
readln(a[i]);
x := ((a[1]+a[2]+a[3])/i)*100;
x := round(x);
x := x/100;
writeln('Введено чисел: ',i,' Среднее арифметическое: ',x);
end;
end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?