В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Aaa1nuchto
Aaa1nuchto
24.10.2021 04:19 •  Информатика

Написать программу вывода max n-числа, где- то от 1 до 100 через массив ,и последующее сравнивать

Ответ:
Никита0088
Никита0088
08.07.2020 18:37
Program primer1;

var
  a: array[1..100] of integer;
  n, i, max, min: integer;

begin
  Randomize;
  Write('Введите число элементов от 1 до 100: ');
  Readln(n);
  max := -32768;
  min := 32767;
  Writeln('Исходный ряд чисел');
  for i := 1 to n do
  begin
    a[i] := Random(101) - 50;
    Write(a[i], ' ');
    if max < a[i] then max := a[i]
    else if min > a[i] then min := a[i];
  end;
  Writeln(#13#10, 'Максимум: ', max, ', минимум: ', min);
end.

Тестовое решение:
Введите число элементов от 1 до 100: 24
Исходный ряд чисел
40 -14 -12 13 44 -48 -19 11 -50 -2 -49 -6 45 49 -44 4 -7 -50 -31 18 37 44 30 -2
Максимум: 49, минимум: -50
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?