В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Danrukn
Danrukn
04.12.2022 02:37 •  Информатика

Составить программу, которая подсчитывает для каждого столбца массива а[1..5, 1..6] сумму значений элементов и формирует из полученных сумм одномерный массив b[1..6].

Ответ:
didar6
didar6
06.06.2020 21:07

Программа на Паскале:

Program a1;

Var i, j : integer;

      s : real;

      a: array [1..5, 1..6] of real;

      b: array [1..6] of real;

Begin

  For i:=1 to 5 do

    For j:=1 to 6 do

       readln(a[i,j]);

  For j:=1 to 6 do

    Begin

       s:=0;

       For :=1 to 5 do

           s:=s+a[i,j];

       b[j]:=s

    end;

 Write ('Полученный массив В:');

 For j:=1 to d do

    write(b[j]);

 readln

End. 

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?