В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Julianne11
Julianne11
25.12.2020 06:44 •  Информатика

Написать программу на pascal. вычислить произведение множества значений функции y= 2*a+7 / 3*a-2 при изменяющихся a 6, 7, 7 .. 18.

Ответ:
ghf8
ghf8
08.07.2020 12:17

program znanija_com_task_32583491;

var proizv:real;

   i:integer;

function y(a:integer):real;

        begin

             y:=(2*a+7)/(3*a-2)

        end; {function y}

begin

    proizv:=y(6)*y(7);

    for i:=7 to 18 do

    begin

         proizv:=proizv*y(i);

    end; {for i}

    write('proizvedenie mnozhestva znachenij funkcii y = ',proizv)

end.

{

Как я понял задание, во-первых, функция это дробь с числителем 2a+7, а знаменатель 3а-2. Если всё-таки дробный коэффициент перед вторым слагаемым это легко меняется в теле функции.

Также, мне кажется, что счетчик цикла 7..18 - это 1. То есть, только функция от натурального аргуента. В принципе тоже легко меняется уже в главной программе.

А дальше уже произведение рассчет самого главного: y(6) * y(7) * y(7) * y(8) * ... * y(16).

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?