В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
slyzova1
slyzova1
01.10.2022 17:05 •  Информатика

Написать программу, котораянаходит все углы (в градусах)треугольника со сторонами a, b, c.

Ответ:
arpinan
arpinan
08.07.2020 09:14
        static void Main()
        {
            double a = float.Parse(Console.ReadLine()),
                   b = float.Parse(Console.ReadLine()),
                   c = float.Parse(Console.ReadLine()),
                   al, be, ga;
            if ((a + b <= c) || (a + c <= b) || (c + b <= a))
            {
                Console.WriteLine("No ▲");
            }
            else
            {
                al = (c * c + b * b - a * a) / (2 * c * b);
                be = (a * a + c * c - b * b) / (2 * a * c);
                ga = (a * a + b * b - c * c) / (2 * a * b);
                Console.WriteLine("Alpha: " + Math.Acos(al) * 180 / Math.PI);
                Console.WriteLine("Beta:  " + Math.Acos(be) * 180 / Math.PI);
                Console.WriteLine("Gamma: " + Math.Acos(ga) * 180 / Math.PI);
            }
            Console.ReadKey(false);
        }
Вроде работает...:)
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?