В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Ирина7679
Ирина7679
01.10.2022 17:05 •  Информатика

Информатики, составить программу, складывающую предложенные числа так, чтобы получилось круглое число от 100 до 1000 на языке pascal.

Ответ:
fgf14
fgf14
08.07.2020 09:24
var
  x, y, z: integer;
begin
  writeln('-1 - конец ввода и вывод суммы');
  repeat
    readln(y);
    
    if (y < -1) then 
      writeln('Эм... Не, не съем: отрицательная цЫфра.')
    else
      if (y >= 0) then 
        z := z + y
      else
        if (y = -1) then
          if (z >= 100) then
            break
          else
            writeln('Не, не годится, прибавь ещё чуток, до сотни не дотягивает');
 
    if (z > 1000) then
    begin
      writeln('Всё, перевес. Сумма чисел больше 1000.');
      exit;
    end;
    
    until (false);
  writeln('Сумма примерно равна (если округлить) ', round(z / 10) * 10);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?