В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык

1. составить программу для нахождения произведения чисел от 1 до 15 2. дан массив целых чисел. найти max элемент

Ответ:
Milenadaw
Milenadaw
08.07.2020 08:56
Program Prod15;

var
  p: int64;
  i: integer;

begin
  p := 1;
  for i := 2 to 15 do p := p * i;
  writeln('Произведение целых от 1 до 15 равно ', p)
end.

Тестовое решение:
Произведение целых от 1 до 15 равно 1307674368000

program emax;

const
  n = 20;

var
  i, amax: integer;
  a: array[1..n] of integer;

begin
  amax := -32768;
  writeln('Введите 20 целых чисел');
  for i := 1 to 20 do
  begin
    read(a[i]);
    if amax < a[i] then amax := a[i]
  end;
  writeln('Максимальное из чисел равно ', amax)
end.

Тестовое решение:
Введите 20 целых чисел
-5 12 0 34 26 -77 11 0 34 -23 7 0 -14 -8 34 -15 27 0 -45 23
Максимальное из чисел равно 34
0,0(0 оценок)
Ответ:
igubaevak
igubaevak
08.07.2020 08:56
1.

#include<iostream>
using namespace std;
int fact(int a)
{
  if(a==1) return 1;
  return fact(a-1)*a;
}
int main()
{
  cout << fact(15);
}

2.

#include<iostream>
#include<cstdlib>
#include<ctime>
using namespace std;

int main()
{
  srand(time(NULL));
  const int n = 10;
  int mass[n];
  int max;
  for(int i=0; i<n; i++)
  {
    mass[i] = rand()%100;
    cout << mass[i] << ' ';
  } 
  cout << '\n';
  max = mass[0];
  for(int i=0; i<n; i++)
    if (max < mass[i]) max = mass[i];
  cout << max;
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?