В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
mafobe66
mafobe66
27.11.2022 23:19 •  Информатика

написать программу. составить блок схему. вставить заданное число в массив целых чисел перед последним четным элементом.

Ответ:
ikoooo43
ikoooo43
08.07.2020 08:36
Const
    m = 10; 
var
    a: array[1..m+1] of integer;
    i, k: integer;
begin     
write ('Исходный массив: ');   
for i := 1 to m do
  begin
  a[i] := random(100);
  write (a[i],'; ');
  end;   
writeln; 
write('Введите число: ');
readln(k);
for i:=m+1 downto 1 do
  begin
  a[i]:=a[i-1];
  if a[i] mod 2=0 then
    begin
    a[i-1]:=k;
    break;
    end;
  end;
write('Измененный массив: ');  
for i := 1 to m+1 do
         write (a[i],'; ');  
end.
написать программу. составить блок схему. вставить заданное число в массив целых чисел перед последн
написать программу. составить блок схему. вставить заданное число в массив целых чисел перед последн
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?