В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
irisha190784
irisha190784
27.11.2022 23:19 •  Информатика

составить блок схему. составить программу на языке паскаль. дан массив в котором все элементы различны. удалить из него минимальный элемент.

Ответ:
arslanbaiguskap0c2gw
arslanbaiguskap0c2gw
08.07.2020 08:42
Const
    m = 10; 
var
    a: array[1..m] of integer;
    i,j, min: integer;
begin     
write ('Исходный массив: ');   
for i := 1 to m do
  begin
  a[i] := random(100);
  if (i=1) or (a[i]<min) then min:=a[i];
  write (a[i],'; ');
  end;   
writeln; 
for i:=1 to m do
  begin
  if a[i]=min then
    begin
    for j:=i to m-1 do
      a[j]:=a[j+1];
    break;
    end;
  end;
a[m]:=0;
write('Измененный массив: ');  
for i := 1 to m-1 do
         write (a[i],'; ');  
end.
составить блок схему. составить программу на языке паскаль. дан массив в котором все элементы различ
составить блок схему. составить программу на языке паскаль. дан массив в котором все элементы различ
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?