В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
lisaBeTa
lisaBeTa
03.05.2022 03:39 •  Информатика

Пусть задана последовательность чисел a, b, c, d. составить программу вычисления количества k положительных чисел, содержащихся в этой последовательности. печатать a, b, c, d, k.

Ответ:
ggg2223333
ggg2223333
08.07.2020 08:29
Var
  a,b,c,d,K:integer;
begin
  write('Введите a,b,c,d: ');
  readln(a,b,c,d);
  K:=0;
  if a>0 then K:=K+1;
  if b>0 then K:=K+1;
  if c>0 then K:=K+1;
  if d>0 then K:=K+1;
  writeln(a,' ',b,' ',c,' ',d,' K=',K);
end.

Тестовое решение:

Введите a,b,c,d: -4 5 3 0
-4 5 3 0 K=2
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?