В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
6666628
6666628
03.01.2023 10:22 •  Информатика

Составить программу в паскале с использованием циклических операторов: три приятеля были свидетелями дорожного происшествия. номер машины(четырехзначный) ни один из них не запомнил. однако один заметил,что этот номер делиться на 2,7 и 11; другой заметил, что в номере учавствуют только две цифры, а третий заметил,что сумма цифр равна 30 . какой номер автомобиля?

Ответ:
АНТО14
АНТО14
01.10.2020 23:03
function colcifr(a: integer): integer;
var
  s, k: string;
  i, j: integer;
begin
  i := a;
  repeat
    str(i mod 10, k);
    i := i div 10;
    if (pos(k, s) = 0) then
    begin
      s := concat(s, k);
      inc(j);
    end;
  until (i = 0);
  colcifr := j;
end;

function sum(i: integer): integer;
var
  a, b: integer;
begin
  a := i;
  repeat
    b := b + a mod 10;
    a := a div 10;
  until (a = 0);
  sum := b;
end;

var
  i: integer;

begin
  for i := 1000 to 9999 do
    if (i mod 2 + i mod 7 + i mod 11 = 0) then
      if (colcifr(i) = 2) then
        if (sum(i) = 30) then
          writeln(i);
end.

8778
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?