Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
lgolar
03.01.2023 10:22 •
Информатика
Составить программу в паскале с использованием циклических операторов: среди всех чисел,меньших к ( к< =999) указать те, сумма цифр которых равна даномучислу n
Ответ:
Artemov9Artem
01.10.2020 23:02
function sum(i, n: integer): boolean;
var
a, b: integer;
begin
a := i;
repeat
b := b + a mod 10;
a := a div 10;
until (a = 0);
sum := (b = n);
end;
var
n, i, k: integer;
begin
readln(n, k);
for i := 1 to k do
if sum(i, n) then
writeln(i);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
Gesha11
24.03.2022 05:27
Какие существуют основные типы величин в программировании...
Gamonga
24.03.2022 05:27
Как записывается команда присваивания...
24051999z
12.01.2021 03:09
Заполнить одномерный массив, состоящий из 20 элементов, случайными числами из промежутка [-100; 100]. вывести элементы и их индексы, кратные заданному числу (число...
steshaaaaa1
12.01.2021 03:09
1) числа фибоначчи определяются формулами: f0=f1=1; fn=fn-1+fn-2 при n =2,3,… т.е., это последовательность вида: 1,1,2,3,5,7,… составить программу определения n-ого...
umsynaiamirova
10.05.2020 03:56
за 2 задания по пайтону : 1) Учениця Марія щодня з 1 до 10 грудня протягом 4 років о 15.00 вела за станом температури повітря й зберігала у щоденнику. Розробіть...
ник4824
12.04.2023 07:07
Нужная вам книга находится на одной из 16 полок. какое количество информации несет в себе сообщение об этом? а) 4 бита б) 3 бита в) 5 бит г) 7 бит...
кракодиллох
03.08.2022 01:49
Решить по информатике! вот условие: ,,дан массив целых чисел (3,4) найти сумму всех элементов массива,,...
POLINAzhavoronkova
03.08.2022 01:49
Нужно составить программу в си++. вывести квадраты и кубы 10 чисел следующей последовательности: 1, 2, 4, 7, 11,...
dimentor13
25.02.2020 12:51
Сколько битов информации содержится в сообщении объемом четверть килобайта?...
GuldanaManarbek
25.02.2020 12:51
Утром, в продуктовый магазин к булок белого хлеба по цене 25 рублей и в булок черного хлеба по цене 23,50 рублей. определить выручку магазина от продажи хлеба....
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
var
a, b: integer;
begin
a := i;
repeat
b := b + a mod 10;
a := a div 10;
until (a = 0);
sum := (b = n);
end;
var
n, i, k: integer;
begin
readln(n, k);
for i := 1 to k do
if sum(i, n) then
writeln(i);
end.