В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык

Написать программу в паскале: в тексте, состоящем из латинских букв и заканчивающеемся точкой, посчитайте количество гласных букв.

Ответ:
AMINA2007133456
AMINA2007133456
01.10.2020 22:59
Const
j=['a','e','i','j','o','u'];
var
a:string;
b:char;
n,i,k:integer;
begin
  repeat
     read(b);
     a:=a+b;
  until b='.';
n:=length(a);
n:=n-1; {без точки}
 for i:=1 to n do
    if a[i]in j then
        k:=k+1;
writeln(k);
end.

     
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?