В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
VafaMurad
VafaMurad
21.03.2022 10:21 •  Информатика

Составить программу в паскале. в массиве x(n) каждый элемент равен 0, 1 или 2. переставить элементы массива так, чтобы сначала располагались все единицы, затем все двойки и, наконец, все нули (дополнительного массива не заводить).

Ответ:
tanushkash05
tanushkash05
01.10.2020 22:54
Const
n=10;
var
a:array[1..n]of integer;
i,j,buf:integer;
begin
   for i:=1 to n do
      begin
         a[i]:=random(3);
         write(a[i]:4);
      end;
{сортирую по возрастанию}
 for i:=1 to n-1 do
    for j:=i+1 to n do
       if a[i]<a[j]then
         begin
               buf:=a[i];
                a[i]:=a[j];
                a[j]:=buf;
         end;
{пересылаю нули в конец масива}
for i:=1 to n-1 do
    for j:=i+1 to n do
       if a[i]=0 then
         begin
               buf:=a[i];
                a[i]:=a[j];
                a[j]:=buf;
         end;
for i:=1 to n do
   write(a[i]:4);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?